Some message threads are failing to render with an error
Incident Report for ProductOS
Postmortem

In the Jellyfish UI we highlight code blocks in messages using the `highlight.js` package. Our implementation tried to highlight the code block using the language specified, however if the language was unknown, an error would be thrown. This would lead to an uncaught exception that prevented the UI from rendering correctly and causing it to display a large error message.

An update to rendition was made that wrapped the rendered in a try…catch block, falling back to trying to highlight the code block automatically: see https://github.com/balena-io-modules/rendition/pull/1138/files .

Posted Jun 19, 2020 - 14:31 UTC

Resolved
This incident has been resolved.
Posted Jun 19, 2020 - 14:27 UTC
Identified
When parsing code blocks in messages, if an unknown language is detected then UI rendering will crash, displaying an error. A fix is being implemented.
Posted Jun 19, 2020 - 11:02 UTC
This incident affected: Jellyfish (UI).